Setting up iRig Keys

Posts: 17
Joined: Fri Apr 05, 2013 5:16 am

Setting up iRig Keys

Postby SienaT » Tue Apr 09, 2013 10:35 pm

Hi folks,

As I've mentioned in a previous post, I'm totally blind and use ThumbJam with Apple's built in Voiceover screenreader. I know there's a bug in prefs/midi options that causes ThumbJam to crash when Voiceover is on (which will be fixed in the next update). This being said, could one of you please send me (or post on here) a step by step guide or audio demonstration as to how to set up my iRig Keys midi controler to work with ThumbJam? Unfortunately I don't always have a sighted person available to help me, but if someone could please explain to me how to set it up, I can explain it to a sighted friend or relative when I get a chance and they can set it up for me. I tried getting my dad and my sister to have a look at it but neither of them have been able to get it set up. I read the manual several times but I didn't quite understand the instructions. IK Multimedia's website said that the iRig Keys would work with ThumbJam, but it doesn't say how to set it up, and like I said in my previous post, the iRig Keys user manual doesn't say anytihng whatsoever about ThumbJam. I asked the folks at Long and McQuade, the music store where I got my iRig Keys, and none of them have ever used ThumbJam, so that was of no help either. Unfortunately I only have a week left to return it to the store, but I'm hoping to get it working as I would hate to have to return it just because I don't know what I'm doing!

Thanks in advance to anyone who can help me. Like I said, I'm still very new to this, so please forgive me for asking a lot of questions, any help would be greatly appreciated

Best regards,

Siena.

User avatar
Posts: 1045
Joined: Tue Dec 15, 2009 3:25 am

Yes, getting the iRig Keys to

Postby Jesse » Wed Apr 10, 2013 9:33 am

Yes, getting the iRig Keys to work should be possible with VoiceOver turned off. First, before starting ThumbJam, make sure the iRig Keys is plugged in to the device. Then start ThumbJam. Go to the Prefs, Midi Control, and scroll down until (someone) sees Midi Input Connections. There should be an entry there for the iRig Keys, and you want to press the button on that row to enable Voice Input. That should be it! You shouldn't have to go back there once set up, as it should store the preference to enable it the next time it sees it.

Regarding the input control mode, there is actually a separate glide control for the input control mode that is on the panel that pops up to the right of the main input control toggle button. Unfortunately the voiceover doesn't work properly in that panel once you hit the play area once. So right after you enable input control mode, you should be able to swipe to iterate through the controls, you will hear Input Snap Mode, Octave offset down, octave offset up, Threshold, Velocity, and finally Glide. That last one you want to set all the way down to zero (using the standard accessible swipe down gesture for an adjustable control). You also probably want to set that Input Snap Mode to Chromatic (which is the second state of 3, sorry it doesn't properly declare the accessible values!).

I hope that helps.... (also responded via email)

Posts: 17
Joined: Fri Apr 05, 2013 5:16 am

Hi Jesse, Just wanted to let

Postby SienaT » Thu Apr 11, 2013 9:47 pm

Hi Jesse,

Just wanted to let you know that my sister and I were able to get my iRig Keys set up to work with ThumbJam! All is well.

There's just one little thing I'm a bit concerned with and am not sure how to fix it: The notes I hear when playing using the iRig Keys do not correspond to the keys I'm pressing, the whole thing is transposed a semitone above what it's supposed to be, for example, Middle C sounds like C Sharp etc. My scale is set to chromatic, and in the key control, I selected C as the key I want to play in. Apparently this does not seem to solve the problem. I was wondering how I can go about fixing this?

Thanks again for all your help!

Best wishes,

Siena.

User avatar
Posts: 1045
Joined: Tue Dec 15, 2009 3:25 am

It sounds like you might have

Postby Jesse » Thu Apr 11, 2013 11:19 pm

It sounds like you might have Scale Lock turned on, you want to set that to OFF. Find it in the MIDI Control page in the Input Options section. You might be able to get it with VoiceOver turned on if you don't scroll down too much to trigger the crash.

By the way, the updated version that fixes that bug (and adds some other features) is waiting for review by Apple, so probably about a week away.

Posts: 17
Joined: Fri Apr 05, 2013 5:16 am

Thank you so much! I updated

Postby SienaT » Sun Apr 21, 2013 9:45 am

Thank you so much! I updated to the latest version, and it's working great! Was able to get my iRig Keys to work again by going into midi input connections with Voiceover.

Thanks!

Return to Miscellaneous

Who is online

Users browsing this forum: No registered users and 1 guest