ThumbJam and Orphion

Posts: 10
Joined: Sat Jul 07, 2012 11:52 am

ThumbJam and Orphion

Postby mprove » Sat Sep 01, 2012 9:39 am

I want to control ThumbJam from Orphion. But I cannot get it to work. Do others have more luck?

# midi

User avatar
Posts: 1040
Joined: Tue Dec 15, 2009 3:25 am

It works fine, just set the

Postby Jesse » Sat Sep 01, 2012 3:37 pm

It works fine, just set the following options in ThumbJam:
In Prefs->MIDI Control:
Use CoreMIDI = ON
Active in Background = ON
Omni Mode = ON

In Orphion's MIDI settings:
MIDI Output = ON
Multiple MIDI channels = ON
Send Pitchbend = OFF (try on if you want to experiment with it)
Send Pressure = OFF (you can also experiment with this and TJ's corresponding options)

That's it!

Posts: 10
Joined: Sat Jul 07, 2012 11:52 am

sounds good - just not for me

Postby mprove » Sat Sep 01, 2012 5:03 pm

sounds good - just not for me yet.
e.g. SelineHD shows up as MIDI input Connection in ThumbJam -- Orphion does not.

I have an iPad 1st gen with iOS 5.0.1. Both apps have the latest versions installed. I keep on trying... 'would love to play your Hang with Orphion :: http://soundcloud.com/audimprove/hang-1

User avatar
Posts: 1040
Joined: Tue Dec 15, 2009 3:25 am

Hmm, I did the exact

Postby Jesse » Sat Sep 01, 2012 5:19 pm

Hmm, I did the exact instructions I just posted and Orphion plays TJ for me. It is normal for Orphion to not show up in TJ because it doesn't have its own virtual port, but if you set it up for sending, Orphion sends to ALL applications that do. For what it is worth, I started TJ before Orphion, perhaps killing them both, and starting in that order may help?

Posts: 10
Joined: Sat Jul 07, 2012 11:52 am

yes! I even shut down the

Postby mprove » Sun Sep 02, 2012 1:31 am

yes! I even shut down the iPad and restarted. Then 1st ThumbJam with the settings above. Then Orphion. Guess what, it works. :)

Posts: 10
Joined: Sat Jul 07, 2012 11:52 am

Hi Jesse, the MIDI connection

Postby mprove » Fri Sep 07, 2012 2:35 pm

Hi Jesse,
the MIDI connection between Orphion and ThumbJam remains shaky for me. When it works it is stable. But e.g. selecting a new layout in Orphion (long touch to select a new layout) bears the high risk that ThumbJams goes sleeping in the background, i.e. when I switch to TJ to take a look, I see the spinner on the splash screen. Then back to Orphion and then it works again.

One idea: Do you think it is possible to apply the tilt and shake sensors in TJ while the keys are remotely controlled from other apps. Touch in Orphion -> Midi to TJ -> and then the sound gets modified as defined in Edit->Control, but just the gyro sensors ;-)
-Matthias

User avatar
Posts: 1040
Joined: Tue Dec 15, 2009 3:25 am

Well, it sounds like you are

Postby Jesse » Fri Sep 07, 2012 4:14 pm

Well, it sounds like you are running dangerously close to your RAM capacity to hold all the apps you want to run, if iOS is killing ThumbJam in the background even if you recently ran it. Unless TJ actually crashed while in the background. Perhaps that's why it worked fine after that reboot? Do you practice frequent killing of apps in the multitasking bar (double-tap home button) to keep your resources as free as possible?

Regarding accelerometer in the background, I think Apple frowns on that.... but it would theoretically work (I think) if I let those events continue.

Posts: 10
Joined: Sat Jul 07, 2012 11:52 am

I have the 64GB iPad 1st

Postby mprove » Fri Sep 07, 2012 4:35 pm

I have the 64GB iPad 1st generation, plenty of apps, but only Orphion and ThumbJam are running. I think the RAM size is 246MB. I have almost all TJ instruments downloaded. Is it too much? TJ Buffer Size is Auto, and polyphony set to 16.
Thanks for thinking about my issues. I can live with it. I am learning how to get it working.

Return to Miscellaneous

Who is online

Users browsing this forum: No registered users and 1 guest