Having trouble with Virtual MIDI

Post Reply
jj_1080
Posts: 15
Joined: Mon Mar 22, 2010 11:37 am

Having trouble with Virtual MIDI

Post by jj_1080 »

When using Beatmaker 2 or NLog Midi to control Thumbjam, I notice a lot of missing notes. Like if I'm playing chords or arpeggios, only a few notes of each chord will ring out. I have the polyphony set to the max. The one thing that makes more notes ring out is playing around with the release times in the Sample options. Still though, I have trouble getting the chords to play as they should and as they would sound if I were playing them in BM2 or NLog without using Virtual MIDI. Any tips or suggestions?

User avatar
Jesse
Posts: 1050
Joined: Tue Dec 15, 2009 3:25 am

What instrument are you

Post by Jesse »

What instrument are you playing in TJ? What is the release time? Voices can quickly add up with fast chords and a higher release time, and TJ doesn't have a foolproof voice stealing mechanism yet, so it just won't play the notes sometimes when it runs out of polyphony too quickly.

I am in the process of fixing it, just another reason the release has been delayed.

jj_1080
Posts: 15
Joined: Mon Mar 22, 2010 11:37 am

I defintely notice it with

Post by jj_1080 »

I defintely notice it with the pianos and guitars. The release times where I get the most polyphony range between 10 and 400ms depending on the instrumet but I still notice one or two notes not being played. Anything higher than that, I lose almost all polyphony. I didn't have a problem with it using the stacatto violins which I guess makes sense because they're very short sounds and the release times don't really mean anything.

jj_1080
Posts: 15
Joined: Mon Mar 22, 2010 11:37 am

Oh, and as much I want the

Post by jj_1080 »

Oh, and as much I want the next update, take the time you need. You do great work and that takes time.

Post Reply