dsmidi wifi - Ableton Live - Ad Hoc network

Posts: 4
Joined: Sun Oct 17, 2010 6:22 am

dsmidi wifi - Ableton Live - Ad Hoc network

Postby Deejaykep » Sun Oct 17, 2010 6:43 am

hi , Congratulations for all you've done i use thumbjam on scene and it really fantastic .

I'll try many times to use dsmidi with my macbook but when i create private adhoc network beetween iPhone and mac dsmidi doesn't work .
It work via regular connection but no in adhoc .

Do you have a trick ? for that

I used Private ip : or
and routeur : or
and iPhone same xxx.xxx.xxx.2

Must be a solution !!


User avatar
Posts: 1045
Joined: Tue Dec 15, 2009 3:25 am

OK, I'm doing it step-by-step

Postby Jesse » Fri Dec 17, 2010 9:00 pm

OK, I'm doing it step-by-step right now and will list the steps:

1. Set up Ad-hoc network on mac, click the wifi menu and choose Create
Network... I just let it pick the defaults and don't specify a

2. On your device, go to the system Settings, Wi-Fi page, choose the network
you just created (it should show up).

3. Now, with iOS 4.x and backgrounding, make sure ThumbJam is not
already running: double-tap home button to bring up taskbar and press
and hold the TJ icon until the remove indicator shows up, then tap the
red indicator to kill it.

4. Start up TJ on your device, go to Prefs->Remote Control and turn on
Send MIDI via DSMI

5. Start up DSMidiWifi on your mac

6. I use an application on the mac called MidiMonitor to verify events
are flowing, but it worked fine in Ableton Live too.

7. If it doesn't seem to work, just quit and start DSMidiWifi
again once your target midi application is running and then it works.

User avatar
Posts: 1045
Joined: Tue Dec 15, 2009 3:25 am

I just tried it with Live

Postby Jesse » Fri Aug 12, 2011 10:45 am

I just tried it with Live 8.2.1 and it all worked fine as long you turned on some kind of monitoring on the midi track (On, or Auto when recording). I simply had a single midi track with an instrument AU inserted on it, set monitoring to On and from TJ via DSMI (as set up above) just worked. Recording worked as well. It looks like I have DSMidiWifi v 1.02, running on OSX v10.6.7.

When the next version of TJ comes out, you can throw DSMI away because TJ supports CoreMidi now.

Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest