pitch/tempo change weirdness in version 2 ... ?

Posts: 21
Joined: Thu May 26, 2011 12:14 am

pitch/tempo change weirdness in version 2 ... ?

Postby ClassicalFan » Sun Dec 11, 2011 2:17 pm

I've been working quite a bit with TJ2 (really nice upgrade, thanks so much), and in the past few days have noticed a few bits of weirdness related to pitch (and possibly tempo) stability:

Yesterday I was doing a lot of work trying to get the right harmonizations for a melody, so my workflow was something like this (using my iPad 2, up-to-date version of iOS 5):

1. record a loop containing a few phrases of my melody (nothing special, mandolin playing one note at a time, minor scale)
2. play it a few times, trying different chords along with it
3. Leave TJ and go to my notebook program (UPad) or my music transcription program (Symphony Pro), where I write down the harmonizations that I think worked best.
4. Back to TJ, repeat from step 2 until I've got something I like.

This was the first time I've done anything like this since the upgrade, though I have done it quite a bit using TJ1, without problems.

What's happening is, sometimes when I go back to TJ all of the pitches are off. I haven't been really systematic in figuring out exactly what's happening, because I was focused on getting my harmonizations done, but sometimes the looped sound would play several tones higher or lower than they were recorded at, like the whole thing was bumped up to a different key (I couldn't tell if the tempo changed also, and didn't stop to diagnose that); other times, the loop would be fine, but when I played along with the loop in TJ the instrument was playing several tones high or low. It was a simple melody, I could tell right away that things were just being transposed. The loop and the instrument play didn't match at all.

Sometimes, actually quitting TJ (double-click the Home button on my iPad, click-and-hold on the TJ icon, click the red X) and re-launching it solved the problem. Sometimes not. In those cases, actually quitting all of the apps I had launched (which was only Symphony Pro, UPad and TJ) worked ... so I was always able to get myself back to proper pitches. But it was really weird.

I thought maybe it was because I had used the new custom note range feature, where I had extended the scale so just a few notes above the tonic appeared at the top of my display. So I reset the scale to its default, ending with tonic on top. Unfortunately, I wasn't systematic enough about my investigations that I could tell for sure if that stopped the weirdness from happening. I'm thinking not, but I wasn't in full troubleshootin' bug-squashin' mode, so I didn't make notes of all that.

Possibly related issue, I'm still investigating: Some of the sessions I recorded around the time of the upgrade are, when I play them again, playing unbelievably fast (I just know I can't hit all those notes that fast, I couldn't have recorded it that fast). Like I said, I'm still investigating this one -- so far, I've only played those sessions by loading them as loops back into TJ or by clicking the play button in TJ's export/copy pane. I can report more once I've really looked into things, played the songs on my computer, analyzed the loop files, looked at the dates, etc. I also am not sure yet if the pitch has changed on these sessions, or just the tempo. But since changing pitch and changing tempo are often related, I thought I'd mention this along with the previous weirdness.

I've looked through the forums and haven't found any other reports of behavior like this -- though quite possibly I just missed something, so my apologies if this is a known bug and yesterday's news.

User avatar
Posts: 1045
Joined: Tue Dec 15, 2009 3:25 am

I have heard of one other

Postby Jesse » Sun Dec 11, 2011 2:42 pm

I have heard of one other report similar to the pitch discrepancy you are seeing, although in that case it was less than semitone. If it happens again (please try by running those other apps, etc) try to note exactly how far off you are seeing it.

I have a suspicion that the other apps could possibly be setting the system samplerate to 48000, and TJ doesn't notice that when it comes back, but it sounds like there are a lot of confusing factors. I would be very interested in what you find out when you export some of those sessions and loop sets to your computer, and I would be happy to take a look at them as well.

User avatar
Posts: 1045
Joined: Tue Dec 15, 2009 3:25 am

Out of curiosity, how are you

Postby Jesse » Wed Dec 14, 2011 12:08 pm

Out of curiosity, how are you listening, via headphones, line-out, internal speaker, or bluetooth?

Posts: 21
Joined: Thu May 26, 2011 12:14 am

Here's what I've found from

Postby ClassicalFan » Wed Dec 14, 2011 5:18 pm

Here's what I've found from some more systematic experimentation:

Only one app causes the issue (at least, of the music apps I have): Symphony Pro.

Symphony Pro is running in the background, even if all I've done is launch the app and immediately parked it, when I launch TJ everything plays at a raised pitch -- somewhere between a semitone and a whole tone (compared to me reproducing the notes on a piano).

As soon as I completely quit Symphony Pro (double-click to get the row of icons at the bottom of the screen and close it there), the pitch in TJ goes back to normal. I don't have to quit TJ, or even park it, to have the difference resolve itself.This also happens regardless of which of the two apps was launched first.

Normally, I work using the internal speakers on my iPad, but I tried using my headphones (not bluetooth, I don't have any of those), and the result is the same.

I also tried recording two sessions of a chromatic scale playing in TJ, one with and one without Symphony Pro running. When I was in TJ recording the session, the pitch difference was obviousl But when I transferred the two session files over to my Mac and opened them in my audio editor (Amadeus Pro), they played at identical pitch. So the difference isn't in anything that TJ is recording ... it's just how the iPad is putting the sound out.

I haven't had any problems with Symphony Pro until recently (possibly when iOS 5 came out), and now it's behaving a little strangely. So clearly something is going on there that has nothing to do with TJ.

So yay, this is a very limited problem after all ... and easily enough solved, by making sure Symphony Pro isn't running (though it does make going back and forth a bit slower). I hope my diagnostics have helped you figure out what might be going on.

User avatar
Posts: 1045
Joined: Tue Dec 15, 2009 3:25 am

Yes, that helps! However,

Postby Jesse » Wed Dec 14, 2011 5:26 pm

Yes, that helps! However, I've had reports from others with different kinds of pitch change strangeness, and I wonder if other apps might do a similar thing, if it is actually the sample rate changing issue that it sounds like.

I guess I'll buy Symphony Pro and find out!

Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest