Wifi Transfer Issues

Posts: 4
Joined: Wed May 04, 2011 7:03 pm

Wifi Transfer Issues

Postby JustinSire » Wed May 04, 2011 7:17 pm

Hello, great app.

I'm encountering a weird problem when I try to transfer my creations from my iphone to my pc. I follow the instructions and find the upload page just fine, but the files themselves act strangely. I was able to successfully transfer and then download 3 loopsets. After that, the loopsets I downloaded give me the error message "Unexpected end of archive" when I try to unzip them.

The problem continues, as once I download a file and it gives me this message (which is everytime I try to download a file now) any other file I try to "create archive" with does not respond. By this I mean I click "create archive" and the page refreshes with no changes. There is no option to download the archive I just created (and I doubt it did create the archive to begin with). Furthermore, when I try and go back and re-download the loops I've already created an archive for, they download immediately without a download time (nothing is transferred) and are empty zips.

I'm pretty perplexed by this whole thing, I love this app, and I want nothing more than to get these loops on my pc so I can work with them, but I can't seem to figure out what the problem is. If it makes a difference, I haven't updated my iphone or thumbjam app in over 7 months out of fear it will write over my saved loops.

Any help would be greatly appreciated.

User avatar
Posts: 1045
Joined: Tue Dec 15, 2009 3:25 am

Wow, I haven't seen that

Postby Jesse » Wed May 04, 2011 9:29 pm

Wow, I haven't seen that issue before. I tried to reproduce it but haven't been able to yet.

That said, you can manually grab the WAV files for each loopset off one at a time by doing the following:
Add the following to the web address you usually use to connect to the web interface: /LoopSets/
You should see a listing of folders, one for each of your LoopSets (each foldername ends with .loopset). You'll also see any archive ZIP files that were created before. Click on one of the folders and you'll see two files and a folder called sounds inside it. Click on sounds and the WAVs will be there, which you can download one a time by clicking (or right clicking and download as...).

Anyway, do a reboot of your device (hold down the sleep button for 10 seconds or so), then try the normal procedure again to see if it helps at all. Also, be sure your device does not go to sleep when doing the wifi transfer stuff.

Posts: 4
Joined: Wed May 04, 2011 7:03 pm

Hey, thanks for your fast

Postby JustinSire » Wed May 04, 2011 11:11 pm

Hey, thanks for your fast response.

I tried adding that line to the end of my normal connect address and it brought me to a page called "Files From", however the only thing listed on this page was a link titled "..." and a "upload file/browse and submit" option. After clicking on the link it redirected me back to the normal web interface. Also, I previously had auto-lock set to 1 minute. I disabled this on the iPhone and tested it once more. I was able to successfully create an archive and then download one loopset, however when I tried to do another it went back to creating the download archive immediately, then downloading immediately, and then giving me the same "unexpected end of archive" when i open the zip.

What is more distressing is that once I create a download link for a particular loopset, that download link stays on the web interface in its corrupted form. I figure I can work around this by renaming the loopsets once I find a fix for the upload/download process, but as of yet nothing seems to work. I should note, I have restarted my ipod many times and ensured my wifi connection.

The page you directed me to sounds interesting but as I mentioned when I navigated to it what I saw was different from what you described. Again, I appreciate your help and look forward to any suggestions.

Posts: 4
Joined: Wed May 04, 2011 7:03 pm

edited: Alright, so after

Postby JustinSire » Wed May 04, 2011 11:38 pm

edited: Alright, so after restarting again (everything), I tried the address once more and was able to navigate to the folders you outlined in your response and download one of the loops. However then I found another crazy problem. I see the .loopsets files and they are all listed at 0.2 KB, and after I click on them, they take me back to the "..." link, when I click that it brings me back to the list of loopsets, and so on and so forth, in a vicious cycle.

Here is an example of what it shows:

Default.loopset/ ( 0.2 Kb, 2010-05-02 01:13:22 -0400)
Default.zip ( 148.0 Kb, 2011-05-04 23:16:50 -0400)

Obviously the loopset should be larger (like I said clicking on it just redirects me back to the "..." link).
Downloading the zip provides me with the same error: "C:\Documents and Settings\Justin\Desktop\Default.zip: Unexpected end of archive"

Posts: 158
Joined: Sun Feb 21, 2010 11:46 am

I can't really help you on

Postby mat » Thu May 05, 2011 6:36 am

I can't really help you on your main problem, but I don't get why you don't update TJ and/or your iPod, this will certainly not erase your loops and loopsets (never did to me anyway).


User avatar
Posts: 1045
Joined: Tue Dec 15, 2009 3:25 am

What version of ThumbJam do

Postby Jesse » Thu May 05, 2011 9:09 am

What version of ThumbJam do you have right now?

Can you get to the /LoopSets/ page again and do a save page as (HTML) from your browser? Then post that here or email it to me at support@thumbjam.com. Did you try all the loopset folders? They really shouldn't be empty if you can successfully load them in the app.

Posts: 4
Joined: Wed May 04, 2011 7:03 pm

I currently have version

Postby JustinSire » Thu May 05, 2011 5:18 pm

I currently have version 1.2

Sometime when I restart my device and run through the procedures, I am able to navigate to the sound folder and then individual loops of a loop set and download them all. However once I go back to a different loopset (always after having already downloaded another) all the others act like they dont exist. By that I mean I click on it and it reverts me back to the "..." link, etc...

I'll link to the saved HTML: file:///C:/Documents%20and%20Settings/Justin/Desktop/Files%20from.htm
I dont recall ever linking a file this way, so if a simple link isnt sufficient, and it needs an upload: http://www.megaupload.com/?d=NT2JJ6OV

Like I said I haven't updated either my phone or app in a long time on the off chance it would wipe the saved loops, but I have no problem doing so (to see if it fixes anything) if this is not the case.

User avatar
Posts: 1045
Joined: Tue Dec 15, 2009 3:25 am

Please upgrade to the latest

Postby Jesse » Fri May 06, 2011 12:07 am

Please upgrade to the latest (1.3.2), it won't wipe any of your saved loops. Let me know how it works with the new version.

Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest