TJ loses capacity to bend notes

Posts: 14
Joined: Thu Jun 04, 2015 10:10 am

TJ loses capacity to bend notes

Postby smwells5 » Fri Oct 23, 2015 11:29 am

This is actually a TJ bug that has plagued me for a long time. I've just now found a way to consistently reproduce it, and create a video example.

The problem is when pitch-bend is set in the controls (I use V.Lnv Tilt), and you are playing music with a lot of successive notes without lifting your finger from the screen, the bend function ceases, and you are left in a condition that is as if you never had pitch-bend turned on.

I expect this is some kind of buffer over-run, where the memory allocated for bend info is exhausted, so you are no longer able to bend notes.

I use pitch bend on V.Lin Tilt a lot, not just for note bending, but for vibrato, as I prefer the control that it affords over the vibrato/tremolo function. Just FYI, I find the problem most consistently reproducible when I also have vibrato and tremolo set to 'Shake' in addition to pitch-bend set to V.Lnv Tilt.

I love TJ, and fixing this issue would make it not just a great app, but a Super app! - Thanks

Here's the link to a youtube video I made demonstrating the bug:

https://youtu.be/lgkST6r98mQ

User avatar
Posts: 1020
Joined: Tue Dec 15, 2009 3:25 am

Re: TJ loses capacity to bend notes

Postby Jesse » Thu Oct 29, 2015 12:06 pm

I have seen this bug, but not nearly as often as your video shows. I'll experiment with your settings to see if it helps me track it down....

Posts: 14
Joined: Thu Jun 04, 2015 10:10 am

Re: TJ loses capacity to bend notes

Postby smwells5 » Thu Jul 14, 2016 9:51 pm

I was sad to find that the latest version of Thumbjam (2.5) didn't include a fix to this bug - the only thing in my mind that keeps TJ from providing a professional quality instrument.

Any chance of getting this fixed in a future release?

Steve

User avatar
Posts: 1020
Joined: Tue Dec 15, 2009 3:25 am

Re: TJ loses capacity to bend notes

Postby Jesse » Tue Jul 19, 2016 1:43 pm

Ugh, this one dropped off my list when I was working on the last update. I've just put it on my current buglist, thanks for the reminder.

User avatar
Posts: 1020
Joined: Tue Dec 15, 2009 3:25 am

Re: TJ loses capacity to bend notes

Postby Jesse » Tue Jul 19, 2016 1:49 pm

Aha, I can only reproduce this when you place a second finger down (at least once) while keeping the original down, then after releasing the second finger the tilt bend no longer works on the first held finger. I can't reproduce this at all if only one finger is ever used. Could it be there might be some accidental (or intentional) additional touches happening on your end? The good news is I know exactly what the issue is the way I reproduce it.

Posts: 14
Joined: Thu Jun 04, 2015 10:10 am

Re: TJ loses capacity to bend notes

Postby smwells5 » Tue Jul 19, 2016 3:27 pm

Thanks for responding. ... I'll be patent - lol.

What I've found about this bug is that the frequency of occurrence is in some way related to the instrument in use.

So for instance, when I use Wahtooth, it happens relatively rarely. However, when I use the TE Wind Instruments, (Alto Sax or derivatives there of, in particular), it happens fairly frequently.

Is there a buffer specific to each instrument (the size of which may vary for different instruments) that is being overrun?

This occurs most frequently following a slur of several notes (not lifting the finger in between notes) and then attempting to bend the final note that is landed upon.
Last edited by smwells5 on Tue Jul 19, 2016 4:09 pm, edited 1 time in total.

User avatar
Posts: 1020
Joined: Tue Dec 15, 2009 3:25 am

Re: TJ loses capacity to bend notes

Postby Jesse » Tue Jul 19, 2016 3:37 pm

And you are absolutely sure that another finger (or part of hand, or anything) did not touch the screen when it happens?

Posts: 14
Joined: Thu Jun 04, 2015 10:10 am

Re: TJ loses capacity to bend notes

Postby smwells5 » Tue Jul 19, 2016 4:13 pm

Absolutely certain. Using just my thumb, so not much opportunity for additional touches. And it has happened more than 1000 times (you can tell I use this app a lot), so it wasn't a one-time accidental slip.

btw, I'm using an iPhone 5s (IOS 9), in case it may be hardware related. I also use a 5th gen iPod - which also exhibits the problem.

Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 2 guests