Sending slide messages via MIDI and getting them to play back the same way?

Posts: 10
Joined: Wed Nov 03, 2010 9:43 pm

Sending slide messages via MIDI and getting them to play back the same way?

Postby Littlemachine » Tue Nov 22, 2011 9:59 am

I love the new features of Thumbjam, especially to finally be able to edit my performances via MIDI. It doesn't behave as I expected though, don't know if I'm doing something wrong or what I want is simply not possible?

What I want basically, is to send my performance to Cubase, including slides especially, and then have Cubase play it back to thumbjam exactly as I played it. When using slides however, it just doesn't seem to catch the messages correctly. Playback of the recorded MIDI file, stutters in a way I didn't play. I've tried enabling the different options, like send continuation NRPN but that doesn't work. (I have "send pitchend" enabled, of course) and it does transmit pitchbend, but the transition between notes does not play back the same way. Is there something I can do in Cubase maybe, or is this just not possible?

(I have Cubase 6.05, iPad 1 and use MIDI via wifi rtpMIDI)

Posts: 10
Joined: Wed Nov 03, 2010 9:43 pm

Jesse, or anyone, know what I

Postby Littlemachine » Wed Nov 23, 2011 4:42 am

Jesse, or anyone, know what I mean? To get this to work would mean so much to me.

Thanks.

Posts: 53
Joined: Wed Apr 14, 2010 3:42 am

i have the same problem, but

Postby ElectricAlienCat » Thu Nov 24, 2011 3:38 am

i have the same problem, but using a different DAW.

User avatar
Posts: 1013
Joined: Tue Dec 15, 2009 3:25 am

I will try this myself when I

Postby Jesse » Thu Nov 24, 2011 8:38 am

I will try this myself when I get a chance, but I'm guessing if the issue is getting a smooth slide, then you would need to have the Send Continuations turned on, and perhaps the sequencer isn't recording them or playing them back? They are just NRPN CC messages, but you never know that assumptions people make.

Posts: 10
Joined: Wed Nov 03, 2010 9:43 pm

I have send NRPN

Postby Littlemachine » Thu Nov 24, 2011 9:49 am

I have send NRPN continuations turned on in Thumbjam, as I wrote in my post. When looking at the MIDI file in Cubase, what seems to be recorded, apart from the MIDI notes, is Velocity, Pitchbend, CC6 (DataEnt MSB), CC98 (NRPN LSB) and CC99 (NRPN MSB). But when playing back to Thumbjam, the smooth slides get lost. There's no option for "receive continuation NRPN" in TJ, only send, could this be the issue?

I love using TJ as a MIDI controller, the expressiveness is fantastic, but it's hard to make a perfect performance - being able to edit them and sending them back to Thumbjam is crucial IMO. I hope I'm just missing something obvious?

Posts: 10
Joined: Wed Nov 03, 2010 9:43 pm

Did you ever get around to

Postby Littlemachine » Fri Dec 09, 2011 5:19 am

Did you ever get around to trying this Jesse? It would be great to know just if it's a known limitation or I'm doing something wrong.

User avatar
Posts: 1013
Joined: Tue Dec 15, 2009 3:25 am

Yes, there were several bugs

Postby Jesse » Fri Dec 09, 2011 2:47 pm

Yes, there were several bugs in this area preventing it from happening correctly, all of which have been fixed here for the upcoming bugfix release.

Posts: 10
Joined: Wed Nov 03, 2010 9:43 pm

Oh, good to hear! Thanks a

Postby Littlemachine » Sun Dec 11, 2011 6:57 am

Oh, good to hear! Thanks a lot!

Return to Technique

Who is online

Users browsing this forum: No registered users and 1 guest