Can't transfer with Wifi

Post Reply
Posts: 3
Joined: Tue Apr 26, 2011 8:03 am

Can't transfer with Wifi

Post by Vonnieeeee »

I want to transfer items with Wifi, but it isn't working. What i'm I doing wrong...?
I have enabled the server button and typed the adress in Safari. Safari can't find the adress, so I can't transfer files.

Did I do something wrong?

User avatar
Posts: 1050
Joined: Tue Dec 15, 2009 3:25 am

You need to be sure that your

Post by Jesse »

You need to be sure that your computer and your device are actually on the same local network. On your computer, go to System Preferences , Network.. and if your computer is on wifi, select Airport on the left and then see what IP address you have on the right side of the page. If you have wired networking on your computer, select Ethernet and see what it says there for the IP. The IP addresses should be very similar (usually the same first 3 numbers) on your computer and your iOS device. If not, it is possible they are not actually on the same network.

Another thing to keep in mind is that currently there is an issue with ThumbJam that if you start it on one wifi network, but then move to another one, it may not pick up the new address. You have to quit ThumbJam (double-tap the home button from the main home screen on the device to bring up the task-bar, find TJ icon, press and hold until the red remove indicator appears, then press the red indicator on the icon to quit it), then start it again to get the new network to be used.

Also, be sure that your device doesn't go to sleep, that will prevent the networking from being active.

Posts: 27
Joined: Fri Apr 22, 2011 12:42 pm

I've noticed a weird bug with

Post by raketemensch »

I've noticed a weird bug with this functionality...

It seems like the IP address the server tries to bind to isn't always the current IP address the phone/ipad has assigned to it.

For example, I got home yesterday and used the ipad for a couple of hours on my home wifi, but when I went to use the wifi transfer, it still listed the IP address I had been assigned while at work during the day.

Is it possible that it's caching the IP address it had when you last loaded the app from scratch? Like, if the app is completely shut down, then opened while on wifi network A, TJ caches the ip address. The user then switches out to whatever other apps they use, continue through their day, yatta yatta. Then at night, on wifi network B, the pull up the "Transfer" dialog and it still has the IP from earlier in the day?

Maybe when the "Transfer" dialog loads, it should do a fresh check of the IP address?

(pure conjecture on my part)

Posts: 3
Joined: Tue Apr 26, 2011 8:03 am

I've tried it again today and

Post by Vonnieeeee »

I've tried it again today and it's working!
I really don't know what went wrong, but i'm glad it's working.
I was on the same network (at home), so that couldn't be the problem.
Anyway, when i have problems again i will remember your tips.


Posts: 41
Joined: Tue Apr 06, 2010 11:24 am

This might fall in the

Post by jorgren »

This might fall in the category of a few problems I've had. For example, if I am running TJ, and then I go set up WiFi and return to TJ, TJ can't see WiFi. You need to fully exit TJ (kill it from running in the background). That will jog it to recheck WiFi and IP address.

Post Reply