Multipart use in AUM?

Post Reply
Posts: 1
Joined: Fri Jul 12, 2019 5:39 am

Multipart use in AUM?

Post by Svetlovska »

Hi, noob question here probably but I am trying to set up four ThumbJam instruments inside AUM to be played by the 4 MIDI outputs available inside Aphelian, on my IPad Air 2018 running IOS 12.3, and just can’t work out how to do it. Any help would be appreciated :)

I have loaded up four of the available 8 IAA ‘port’ instances of TJ in 4 Audio channels on AUM, gone into the TJ Settings for the first of these, turned off MPE, selected ‘Aphelian’ as my MIDI source, set the first channel in TJs MIDI in settings from Omni to ‘1’, and that plays fine. However, regardless of what I do in the remaining channels, including using the Split function to load different instruments inside the first instance, I can only get one currently selected instrument in the first TJ channel to play across all 4 instances from the Aphelian MIDI outs, set to 1 thru 4. I have played around selecting the (Virtual) Aphelian port as my ‘In’ on each individual TJ channel, and also tried routing it to them in the AUM matrix view, both individually from Aphelian, or by routing Aphelian into AUMs built in MIDI control. No dice. My understanding is that I ought to be able to select different TJ instruments hosted inside the other AUM channels, and have Aphelian play each of the four parts on different TJ instruments. What am I doing wrong? Thanks!

User avatar
Posts: 1050
Joined: Tue Dec 15, 2009 3:25 am

Re: Multipart use in AUM?

Post by Jesse »

Your setup should have worked, if in fact Aphelian was really sending out to different MIDI channels. One thing to try as a sanity check, is to leave Aphelian out of it and just do the following simple test from within AUM. Set up the AUM tracks and ThumbJam just as you have described. Then use the built-in AUM keyboard, selecting different destinations for it from the wrench (ThumbJam Slot 1, Slot 2, etc) and verify that it plays the instruments that you set up for each slot. You can also test it with the ThumbJam Virtual midi input destination, and then adjust the midi channel it sends (from 1 to 4) to get the same results. This works fine for me here. The latter test should simulate what Aphelian would be doing if in fact it sent things appropriately with separate midi channel numbers directly to ThumbJam.

Also, double-check you set the Channel Start in the MIDI *Input* options (and not the output options) to 1...

Post Reply