Sustain pedal giving priority to new notes

Post Reply
Jonnycube
Posts: 6
Joined: Sat Oct 16, 2010 9:37 pm

Sustain pedal giving priority to new notes

Post by Jonnycube »

I don't think this is a bug, so feature requests seems like the best place to mention it.

ThumbJam is the only app I've found with a sustain pedal, and that's awesome. I also understand that there's a finite number of samples that can sustain at once. But when I sustain a lot of notes, the old voices sustain in favor of the new ones, and the new voices cut out. That is, new voices aren't audible under the previous samples have run their course. I feel like it's obvious it should be the other way around. Is there a technical reason that this is difficult, or is there a benefit to this method that I don't understand?

User avatar
Jesse
Posts: 1050
Joined: Tue Dec 15, 2009 3:25 am

Hmm, it should be the other

Post by Jesse »

Hmm, it should be the other way around already. What instrument were you playing with when noticing this?

Jonnycube
Posts: 6
Joined: Sat Oct 16, 2010 9:37 pm

Whoops, maybe it should have

Post by Jonnycube »

Whoops, maybe it should have gone in bug reports. I'm using an iPad with the grand piano sound. If I hold the sustain button down, after playing exactly 16 notes, all subsequent notes are silent. Until, of course, the initial notes fade, at which point I can play as many new notes as there are faded notes.

Let me perhaps save you some time by saying that I've been using the latest iOS betas as they've been released, so maybe just wait and see if it's a problem after 4.2 is officially released.

User avatar
Jesse
Posts: 1050
Joined: Tue Dec 15, 2009 3:25 am

I think that this must only

Post by Jesse »

I think that this must only happen when holding sustain, if you were to turn off "Release Stops Note" in the sample page for the instrument and then start hitting notes it would do the kind of voice stealing you expect. I must have intentionally special-cased the sustain button there.... I'll look into changing that.


Jonnycube
Posts: 6
Joined: Sat Oct 16, 2010 9:37 pm

I just tried turning off the

Post by Jonnycube »

I just tried turning off the "Release Stops Notes" option, and the grand piano sustains just as I'd expect it to. No new notes getting cut out. It sounds great. The only problem is I can't control the sustaining, like with a sustain pedal on a piano.

mat
Posts: 158
Joined: Sun Feb 21, 2010 11:46 am

My 2cts: could the sustain

Post by mat »

My 2cts: could the sustain behavior be an option, maybe am I totally minoritarian here but I kinda like the way it works right now (leaving the 'oldest' notes ringing until I voluntarily release them with the sustain button) it allows me to control the way the sound elements I'm assembling stop... It could be something in the 'controls' panel: sustain priority to new notes yes/no (no!).
And/or the sustain button could have three positions with the middle one allowing the killing of the oldest or most recently played notes depending on the toggle in the 'controls' menu, the top and low positions just behaving as today (or depending to the toggle, not killing notes but preventing new ones to be played until sustained ones are released).

And BTW, I'll love to have more than 500ms release time as a possibility it would be very useful for some instruments when releasing the sustain in particular...

hope it makes sense...

Post Reply